Nazwy miesięcy w Excelu

Jak wypisać nazwy miesięcy w Excelu? Sposobów jest parę i poniższe 3 na pewno nie wyczerpują tematu, ale jest szansa, że któryś przyda się w Twojej pracy i arkuszu, który akurat tworzysz.

Metoda 1 – formatowanie istniejącej daty

Jeżeli w pewnej kolumnie lub komórce masz datę lub daty, do których chcesz dopisać nazwy miesięcy im odpowiadające, wystarczy użyć funkcji formatującej datę do tekstu – i oczywiście podać ten format. W naszym wypadku format będzie bardzo prosty:

=TEKST(A1;"mmmm") – dla pełnych nazw miesięcy

=TEKST(A1;"mmm") – dla skróconych nazw miesięcy

Kombinacji, zależnie od liczby literek m jest zresztą więcej.

Poniżej jak to wygląda:

Przy formacie podanym bezpośrednio w formule

Nazwa miesiąca w Excelu przy pomocy funkcji tekst i formatu "mmmm"

Przy formacie branym z innej komórki

Nazwa miesiąca w Excelu przy pomocy funkcji TEKST i formatu

Metoda 2 – wybór z listy

A co jeżeli np. chcemy mieć miesiące w konkretnym języku, niekoniecznie zgodnym z językiem Excela?
Bardzo fajne efekty można uzyskać, używając funkcji INDEKS. Da się ją zastosować zarówno z listą nazw miesięcy do wyboru „wbudowaną” w formułę funkcji, jak i z listą podaną w komórkach Excela, zależnie od tego, który sposób jest bardziej dogodny:

Nazwy miesięcy w Excelu wyświetlone funkcją INDEKS z tablicą w formule

=INDEKS({"January";"February";"March";"April";
"May";"June";"July";"August";
"September";"October";"November";"December"};MIESIĄC(A17))

excel-nazwy-miesiecy-funkcja-indeks-tablica-w-formule

Nazwy miesięcy w Excelu wyświetlone funkcją INDEKS z tablicą w komórkach zewnętrznych

=INDEKS($D$33:$D$44;MIESIĄC(A28))

Excel - nazwy miesięcy funkcją INDEKS, tabela w komórkach

Metoda 3 – rozwinięcie listy

Excel dysponuje także pewną sympatyczną funkcją – potrafi rozwijać rozpoczęte listy do bardziej kompletnych. Działa to na liczbach, nazwach dni tygodni i – co w tym miejscu najbardziej interesujące – nazwach miesięcy.

Powodzenia!

VN:F [1.9.22_1171]
Rating: 5.0/5 (1 vote cast)
This entry was posted in Excel by .

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *