Archiwa tagu: excel

Zawijanie tekstu w Microsoft Excel

Zawijanie tekstu w komórkach Excela to funkcja z której warto umieć świadomie skorzystać – przyda się zarówno, żeby obronić się przed domyślnym działaniem Excela nie zawsze zgodnym z tym co chcemy uzyskać, jak i zmusić tabelki do współpracy w sytuacji kiedy dokładnie wiemy jaki efekt jest nam potrzebny.
Do rzeczy – parę przykładów jak można zawinąć lub „odwinąć” tekst w Excelu:

Przełącznik automatycznego zawijania tekstu

Jeżeli do komórki Excela wpiszemy tekst dłuższy niż jej szerokość, to zacznie on „wystawać”:

excel-dlugi-nie-zlamany-tekst-w-komorce

Jeżeli wpiszemy coś do komórki obok, to sąsiad zasłoni pierwszą komórkę:

excel-za-dlugi-tekst-zasloniety-sasiednia-komorka

Żeby tego uniknąć możemy poszerzyć komórkę, jednak przy naprawdę długich tekstach jest to mało praktyczne – lepiej „złamać” tekst.
Excel potrafi to zrobić sam, za pomocą przycisku „Zawijaj tekst”:

excel-dlugi-zlamany-tekst-w-komorce

Ręcznie łamanie linii

Nie zawsze automatyczne zawijanie przynosi pożądany skutek, a czasami wprost chcemy zachować kontrolę nad tym jak nasz tekst się zawinie.

W takiej sytuacji przydaje się umiejętność wymuszenia podziału tekstu na linie.
Zaczynamy od wpisania treści, wymuszając nową linię za pomocą kombinacji klawiszy Lewy Alt-Enter
W czasie edycji (wpisywania) wyglądać to będzie tak:

excel-wymuszone-lamanie-tekstu-w-komorce-wpisywanie

Bezpośrednio po wpisaniu może się okazać, że szerokość komórki mimo wszystko jest za mała:

excel-wymuszone-lamanie-tekstu-w-komorce-oryginalna-szerokosc

i trzeba będzie ją dopasować, rozciągając krawędź nagłówka kolumny i/lub zmniejszając wysokość wiersza:

excel-wymuszone-lamanie-tekstu-w-komorce-zwiekszona-szerokosc

 

Tak przygotowana komórka będzie miała automatycznie włączone „Zawijanie tekstu”
A co gdyby to „Zawijanie tekstu” wyłączyć? Trochę się zepsuje:

excel-wymuszone-zawijanie-wylaczone

Na całe szczęście tak wyglądającą komórkę można przywrócić do sensownego wyglądu, ponownie klikając „Zawijanie tekstu”.

Przykład zastosowania łamania wierszy w Excelu

Na koniec przykład pokazujący lepiej do czego to wszystko można wykorzystać:

excel-zawijanie-wierszy-przyklad-zastosowania

Życzę wielu udanie złamanych wierszy! :-)

VN:F [1.9.22_1171]
Rating: 5.0/5 (1 vote cast)

Jak w Excelu obliczyć procent? Obliczanie udziału procentowego w Excelu

Jeżeli mamy jedną lub więcej wartości liczbowych i chcielibyśmy obliczyć ile wynoszą ich udziały procentowe w sumie ich wszystkich (np. udział poszczególnych pozycji w domowym budżecie), za pomocą Microsoft Excel’a – poniżej wskazówki jak to zrobić.

1. Wpisujemy wartości, których udział procentowy będziemy obliczać

jak-wyliczyc-procenty-w-excelu-krok-1

2. Sumujemy je, aby móc względem sumy wyliczyć udziały procentowe

wyliczanie-procentow-w-excelu-sumowanie-wartosci

3. Obliczamy udział pierwszej wartości wpisując formułę do komórki w której policzymy udziały procentowe, w pierwszym wierszu danych.

Aby uzyskać udział procentowy dzielimy wartość dla pojedynczego wiersza przez sumę wszystkich wierszy.

wyliczanie-procentow-w-excelu-udzial-procentowy-formula

UWAGA! WAŻNY MOMENT! koniecznie pamiętać trzeba, aby w dzieleniu oznaczyć komórkę w której mamy sumę wszystkich wartości znakiem dolara (na ilustracji powyżej to B$9) przed liczbą oznaczającą wiersz komórki. Umożliwi nam to poprawne skopiowanie formuły do kolejnych wierszy, w których wyliczać będziemy udziały.
Bez tego znaku Excel przy kopiowaniu zmieniłby adres komórki z tej zawierającej sumę wartości na kolejne, poniższe.

4. Pierwszy wynik obliczeń – udział wyrażony ułamkiem

wyliczanie-procentow-w-excelu-udzial-procentowy

5. Formatujemy wynik jako procenty

wyliczanie-procentow-w-excelu-zapis-procentowy

zwykle warto zwiększyć dokładność, żeby pokazać także ułamkowe części procentów

zwiekszenie-dokladnosci-wyswietlania-liczb

i gotowe – udział procentowy obliczony!

Poniżej w pełnej krasie wynik obliczeń:

wyliczanie-procentow-w-excelu-formatowanie-procentow-dokladnosc

6. Teraz kopiujemy formułę z komórki, którą właśnie przygotowaliśmy do pozostałych komórek

Ctrl-C, potem zaznaczamy cały zakres…

wyliczanie-procentow-w-excelu-kopiowanie-formuly-na-caly-zakres

i ENTER

wyliczanie-procentow-w-excelu-wyni

Gotowe!

Co możemy dalej zrobić z tak uzyskanymi wynikami?

Pokazać je w bardziej obrazowej formie, przy pomocy reguł formatowania danych:

1. Za pomocą tzw. pasków danych:

oznaczanie-procent-w-excelu-paskami-wybor-paskow

oznaczanie-procentow-w-excelu-paskami

lub kolorów:

oznaczanie-procentow-w-excelu-kolorami-wybor-paskow

oznaczanie-procentow-w-excelu-kolorami

Wyświetlić je na wykresie (dobrze nadaje się do np. tego wykres kołowy):

obliczanie-procentu-w-excelu-wykres-wynikow

Dobrej zabawy z liczeniem procentów!

2015-02-12 Aktualizacja

Nawiązując do pytań z komentarzy i oskarżeń o zwinięcie 28 zł ;-)
To nie do końca tak – komputer nie za dobrze radzi sobie z ułamkami o długim rozwinięciu dziesiętnym (np. 1/3) i generalnie chętniej liczy ze skończoną dokładnością.

Najlepiej widać to chyba na poniższym przykładzie:

roznice-zaokraglen-excel

Po trochu stajemy więc wobec wyboru: albo mamy w miarę dokładnie policzone, wyświetlamy z dużą dokładnością (ale trochę mniej czytelnie) i wynik się zgadza, albo zaokrąglamy i musimy sobie jakoś poradzić z błędami powstającymi w wyniku zaokrąglenia – np. gdzieś ręcznie dodać, co zawsze jest „podejrzane”. W powyższym przykładzie widać, że nawet przy dużej liczbie cyfr po przecinku, z tym szczegółowym „zgadzaniem się” co do najmniejszej części ułamkowej może być różnie.

Ciekawostka: ponieważ tego typu problem z zaokrągleniami pojawia się nie tylko w tak trywialnym przykładzie jak powyżej, ale także np. w rozliczeniach podatkowych, w niektórych przypadkach sposób jego rozwiązania może być uregulowany prawnie lub interpretowany przez instytucję do tego upoważnioną..

VN:F [1.9.22_1171]
Rating: 4.6/5 (10 votes cast)

Jak sumować w Excelu? Obliczanie sumy komórek w Microsoft Excel

Szybkie podsumowanie

Żeby szybko zsumować kilka (podobnie jak kilkaset i więcej) liczb w Excelu, wystarczy je zaznaczyć – np. przeciągając myszką przy wciśniętym lewym przycisku.

liczby-zaznaczone-w-excelu

W pasku stanu, na dole okna programu Excel, zobaczymy kolejno:

wiersz-statusu-z-podsumowaniami-w-excelu

  • średnią zaznaczonych liczb (puste komórki nie są brane pod uwagę, czyli nie zaniżają średniej)
  • liczbę zaznaczonych wartości (puste komórki nie są brane pod uwagę)
  • maksimum wśród zaznaczonych wartości
  • suma zaznaczonych wartości

W taki sposób można szybko podsumować wybrany zakres wartości – zakres ten nie musi być wyłącznie w jednej kolumnie, czy wierszu, zaznaczyć można w ten sposób dowolny zakres komórek, w tym nieregularny, jak na poniższej ilustracji:

podsumowanie-nieregularnego-zakresu-komorek-w-excelu

Suma komórek w kolumnie lub w jej części

Pierwszy opisany sposób jest dobry, żeby szybko sumować wybrane części arkusza, jednak nie daje trwałego efektu.
Żeby uzyskać trwałą i do tego automatycznie aktualizującą się w razie zmiany wartości w sumowanych komórkach sumę liczb, trzeba użyć funkcji.
W polskiej wersji językowej Excela, funkcja ta nazywa się po prostu:

SUMA

Funkcja ta w komórce, w której jest wpisana będzie przechowywała i wyświetlała wartość sumy liczb z komórek, które wskażemy jako argumenty funkcji.

Bardzo szybkie podsumowanie – bez samodzielnego pisania formuł, czyli Autosumowanie

Jeżeli nie chcesz pisać formuł, wystarczy stanąć w komórce pod spodem listy liczb do zsumowania i nacisnąć przycisk „Autosumowanie” dostępny na wstędze Excel’a, w bloku Edytowanie:

autosumowanie-w-excelu

Excel sam spróbuje domyślić się jakie liczby chcesz zsumować i w komórce, w której jesteś zaproponuje formułę SUMA obejmującą zakres, którego się „domyślił”.

autosumowanie-w-excelu-wynik

W razie, gdyby Excel „domyślił się” źle i zakres okazał się jednak nieprawidłowy, można ręcznie skorygować formułę wg. wskazówek poniższych wskazówek.

Szybko, ale dokładniej, czyli piszemy formułę SUMA własnoręcznie

Jak wpisać funkcję SUMA do komórki Excel’a?
Na pewno należy zacząć od znaku równości, żeby Excel wiedział, że chodzi nam o funkcję SUMA, a nie o słowo „SUMA”

Poniżej przykłady:

=SUMA(A1:A5) oblicza sumę wartości komórek ułożonych pionowo w kolumnie A, od wiersza 1 do wiersza 5 (czyli 5 komórek)
=SUMA(A1:F1) oblicza sumę wartości komórek ułożonych w wierszu 1, od kolumny A do kolumny F (czyli 6 komórek)
=SUMA(A1:B5) oblicza sumę wartości komórek ułożonych w prostokąt obejmujący komórki w kolumnach A i B, od wiersza 1 do wiersza 5 (prostokąt ma wymiary 2 x 5 komórek, czyli w sumie 10 komórek)
=SUMA(A1;B2;C3) sumuje wartości z 3 niezależnych komórek A1, B2 oraz C3
=SUMA(A1:A5;C1:C5) sumuje wartości z 2 zakresów – pierwszy zakres obejmuje komórki w kolumnie A, od wiersza 1 do 5, a drugi komórki w kolumnie C, także od wiersza 1 do 5

i słowo komentarza do przykładów:

  • wpisując funkcję należy koniecznie pamiętać o tym, żeby zacząć wpisywanie od znaku równości, następnie wpisać nazwę funkcji, a potem jej argumenty w nawiasach okrągłych
  • każdy argument funkcji SUMA może opisywać jedną komórkę (np. A1) lub spójny, prostokątny zakres komórek (np. A1:B5)
  • funkcja SUMA może mieć takich argumentów jeden (chyba najczęstsza sytuacja) lub więcej – argumenty funkcji przy polskich ustawieniach w systemie Windows, czyli w większości typowych przypadków oddzielane są średnikiem (przy angielskich – przecinkiem)

Tak to wygląda w samym Excelu:

Sumowanie w Excelu w praktyce

Podpowiedź: Suma całej kolumny lub całego wiersza

Jeżeli chcemy zsumować całą kolumnę liczb, to jej adres jako zakresu możemy podać jako:

=SUMA(A:A)

Dla całego wiersza adres taki będzie wygladał następująco:

=SUMA(1:1)

Ważne jest natomiast, aby sama funkcja umieszczona została w takim przypadku poza sumowanym obszarem (np. w kolumnie B w pierwszym przypadku lub w wierszu 2 w drugim przypadku), bo inaczej Excel wyświetli informację o odwołaniu cyklicznym (czyli sumowanie będzie obejmowało „samo siebie”).

VN:F [1.9.22_1171]
Rating: 3.4/5 (22 votes cast)