Sumowanie zmiennej liczby komórek w Excelu

Czasami zakres komórek do sumowania w Excelu chcemy uzależnić od wartości w jakiejś zewnętrznej komórce – np. chcemy móc wpisać liczbę, która powie ile komórek zsumować.

Wygodnym sposobem na osiągnięcie takiego efektu jest funkcja INDEKS

Jak jej użyć? Poniżej przykład pozwalający zsumować w komórce C1 liczbę komórek z zakresu A1:A10, podaną w komórce B1

Przykład 1

Przykład 2

Formuła wpisana w komórce C1, podającej sumę, to:

=SUMA(A1:INDEKS(A1:A10;B1))

czyli sumujemy od komórki A1 do komórki z zakresu A1:A10, o indeksie wskazanym w komórce B1

Przykład 3

Zakres o zmiennym początku i końcu

Można też oczywiście sumować zakres wynikający z wartości w komórkach – np. tak:

W przypadku tej formuły, zarówno początek jak i koniec zakresu sumowania (tutaj – wiersze 5-8), podawane są poprzez wpisy w komórkach B1 i B2:

=SUMA(INDEKS(A1:A10;B1):INDEKS(A1:A10;B2))

W ten sposób możemy zsumować liczby z dynamicznie zmiennego zakresu komórek. Wartości w komórkach B1 i B2 mogą oczywiście także być wynikiem innych obliczeń, a niekoniecznie wpisania wprost, ręcznie.

Przykład 4

Sumowanie w poziomie (kolumny, zamiast wierszy)

Patent działa także poziomo – poniżej sumowanie w komórce A6, wartości z zakresu określonego w komórkach A3 i A4

i formuła:

=SUMA(INDEKS(A1:J1;A3):INDEKS(A1:J1;A4))

One thought on “Sumowanie zmiennej liczby komórek w Excelu

  1. Pingback: Jak sumować w Excelu? Obliczanie sumy komórek w Microsoft Excel

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *